summaryrefslogtreecommitdiff
path: root/boot/uboot
diff options
context:
space:
mode:
authorRonak Desai <ronak.desai@rockwellcollins.com>2015-10-12 13:53:16 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-12 21:59:44 +0200
commit4730df02cf236eefeaf00bec197e398ad12cfeaa (patch)
tree924dce3bf9c81cbd679fd5aef3e896adb31b495e /boot/uboot
parent50963b165d574cf8b7aedf677c60ddb9fe851489 (diff)
uboot: arm64 arch build support
For a 64bit arm architecture, Buildroot uses arm64 terminology and from the top-level Makefile KERNEL_ARCH is set to arm64 which is then passed to the uboot build. This causes a compilation issue as uboot uses the top-level system architecture as it's $(ARCH). So arch/$(ARCH)/Makefile doesn't work with arm64 unless we adjust the arch. [Thomas: - rewrap commit message text. - simplify comment in the code.] Signed-off-by: Ronak Desai <ronak.desai@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/uboot.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index eee0dba23..66e728f79 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -71,7 +71,13 @@ UBOOT_BIN = u-boot.bin
UBOOT_BIN_IFT = $(UBOOT_BIN).ift
endif
+# The kernel calls AArch64 'arm64', but U-Boot calls it just 'arm', so
+# we have to special case it.
+ifeq ($(KERNEL_ARCH),arm64)
+UBOOT_ARCH = arm
+else
UBOOT_ARCH = $(KERNEL_ARCH)
+endif
UBOOT_MAKE_OPTS += \
CROSS_COMPILE="$(TARGET_CROSS)" \