summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-07-13 12:32:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-14 10:30:42 +0200
commit06d126fdc1813dad84c95c2500f400f45853ffae (patch)
tree374d69b49f5c13516910b90a635df9a359d76467 /boot
parent5e94388c57546aa8eff1f7c3cb29ddde052e0b4b (diff)
boot/barebox: check for config file before calling kconfig-package
If we check that the user provides a config file after we call to the kconfig-package infra, the error message we get is the one for the kconfig-package infra, not the custom error message we want to show to the user. So, only call kconfig-package after we do the check. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/barebox/barebox.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 7e530371c..e45976d33 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -109,10 +109,12 @@ define BAREBOX_INSTALL_TARGET_CMDS
endef
endif
-$(eval $(kconfig-package))
-
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
ifeq ($(BR2_TARGET_BAREBOX)$(BR_BUILDING),yy)
ifeq ($(BAREBOX_SOURCE_CONFIG),)
$(error No Barebox config file. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG or BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE settings)
endif
endif
+
+$(eval $(kconfig-package))