summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-05 11:31:08 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-05 12:06:47 +0200
commit1c2eb2684f54cc182783419f1a0f489f5d5ca808 (patch)
tree44076dde8547ac72e8c4442e03c2fd3589d4ab04 /boot
parente6cdb4dd3e32a6de61118cec6237aa75f2a83754 (diff)
boot/uboot: fix build of old U-Boot versions
Since commit 0dca644e443c8f28bfe5aa1c98201dc3b49e1165 ("boot/uboot: fix missing host-openssl for i.MX28 target"), we pass HOSTCFLAGS/HOSTLDFLAGS in the environment of U-Boot when building. This is needed to allow U-Boot to find the OpenSSL headers/libraries when they are needed. Unfortunately, this breaks the build with old U-Boot versions as the U-Boot Makefiles were not designed to have HOSTCFLAGS passed in, which causes some important CFLAGS from the U-Boot build system to be ignored. As suggested by Arnout, we pass the HOST_CFLAGS inside HOSTCC directly, which allows to pass the CFLAGS without overriding the internal U-Boot CFLAGS. Tested with an old U-Boot (2012.10), and a modern U-Boot in a configuration that needs OpenSSL. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index a2274eea7..4e6863dc2 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -93,7 +93,7 @@ endif
UBOOT_MAKE_OPTS += \
CROSS_COMPILE="$(TARGET_CROSS)" \
ARCH=$(UBOOT_ARCH) \
- HOSTCFLAGS="$(HOST_CFLAGS)" \
+ HOSTCC="$(HOSTCC) $(HOST_CFLAGS)" \
HOSTLDFLAGS="$(HOST_LDFLAGS)"
ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)