summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-05-02 23:26:52 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-05-05 11:31:39 +0200
commit2d0bc89ebfda2a8795ed73744c1ffd00c0c4bdcb (patch)
tree6b583a8750c149c83b904542a99850793a9b8501 /boot
parent8b850c32541d7702163509726e0c4e02acb4d8c3 (diff)
uboot: ensure u-boot-dtb.img gets built if enabled
u-boot-dtb.img only gets built by default (all target) if CONFIG_OF_SEPARATE _AND_ CONFIG_SPL_FRAMEWORK are enabled. Certain SoCs (E.G. Action Semi S500) use a proprietary first level bootloader instead of u-boot SPL, but still use u-boot-dtb.img as the first level bootloader parses the uImage header for size/loadaddr. Ensure u-boot-dtb.img gets built if enabled by explicitly listing it as a u-boot make target (next to all) to support such setups. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 48f40c3b6..e071303f7 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -50,6 +50,7 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
UBOOT_BIN = u-boot-nand.bin
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
UBOOT_BIN = u-boot-dtb.img
+UBOOT_MAKE_TARGET = all $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)
UBOOT_BIN = u-boot.img
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMX),y)