summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorFabio Estevam <fabio.estevam@nxp.com>2016-10-07 15:30:34 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-07 22:35:48 +0200
commit55a481bec1a592845c3777705865adb382ece1a3 (patch)
treea85fd31fbf67b805575541c039d3734461f079c1 /boot
parent5af77e67dc996bf19a8c65618b9e3a490281ec3c (diff)
boot/uboot: Call 'make all' unconditionally
Since commit fad58cefa4a392b ("boot/uboot: allow to build multiple U-Boot images") the installation of SPL binary fails. For example, when building the mx6cubox_defconfig target we see: LD u-boot OBJCOPY u-boot-nodtb.bin COPY u-boot.bin MKIMAGE u-boot.img >>> uboot 2016.09.01 Installing to target >>> uboot 2016.09.01 Installing to images directory cp -dpf /home/fabio/buildroot/output/build/uboot-2016.09.01/u-boot.bin /home/fabio/buildroot/output/images/ cp -dpf /home/fabio/buildroot/output/build/uboot-2016.09.01/u-boot.img /home/fabio/buildroot/output/images/ cp -dpf /home/fabio/buildroot/output/build/uboot-2016.09.01/SPL /home/fabio/buildroot/output/images/ cp: cannot stat '/home/fabio/buildroot/output/build/uboot-2016.09.01/SPL': No such file or directory Instead of calling 'make all' only for the BR2_TARGET_UBOOT_FORMAT_DTB_IMG case, call 'make all' unconditionally so that the SPL target can also be installed. Signed-off-by: Fabio Estevam <fabio.estevam@nxp.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 7379a4d13..86e5b84d9 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -48,6 +48,9 @@ UBOOT_MAKE_TARGET += mdbtrick
endif
endif
+# Call 'make all' unconditionally
+UBOOT_MAKE_TARGET += all
+
ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
UBOOT_BINS += u-boot.kwb
UBOOT_MAKE_TARGET += u-boot.kwb
@@ -68,7 +71,7 @@ endif
ifeq ($(BR2_TARGET_UBOOT_FORMAT_DTB_IMG),y)
UBOOT_BINS += u-boot-dtb.img
-UBOOT_MAKE_TARGET += all u-boot-dtb.img
+UBOOT_MAKE_TARGET += u-boot-dtb.img
endif
ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)