summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authortiago.brusamarello <tiago.brusamarello@datacom.ind.br>2016-11-30 08:32:33 -0200
committerPeter Korsgaard <peter@korsgaard.com>2016-11-30 16:10:30 +0100
commitbf5487e21e539e474062ee3ace1ac8fb844e38a2 (patch)
tree6fc7bc456ab5d6aa9873f3af2932e6ee62cd0f0e /boot
parentbf116466d2deb6c9f8f661c08142b43b0f4667e4 (diff)
uboot: support -b option for mkenvimage
When generating the environment image the target endianess should be taken in account for CRC calculation purposes. For big endian targets the -b flag should be passed to the mkenvimage tool. Signed-off-by: Tiago Brusamarello <tiago.brusamarello@datacom.ind.br> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/uboot.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 3e347c108..6b9d54454 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -223,6 +223,7 @@ define UBOOT_INSTALL_IMAGES_CMDS
cat $(call qstrip,$(BR2_TARGET_UBOOT_ENVIMAGE_SOURCE)) | \
$(HOST_DIR)/usr/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
$(if $(BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT),-r) \
+ $(if $(filter BIG,$(BR2_ENDIAN)),-b) \
-o $(BINARIES_DIR)/uboot-env.bin -)
endef