summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorRyan Coe <bluemrp9@gmail.com>2016-09-11 18:04:26 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-12 22:32:47 +0200
commitf80e50d8a7ebcdaa8111963b6df0fe658ade6e5d (patch)
treeff9f37eab6497a087de515e797621a14fe81f6f4 /boot
parentec63228bd53ffb21704dc7ec9a2dcee64506504f (diff)
syslinux: add patch to disable pie
Ubuntu 16.10 has pie enable by default. This causes a build failure with syslinux. https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/1579023 Signed-off-by: Ryan Coe <bluemrp9@gmail.com> [Thomas: improve patch description.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/syslinux/0002-disable-pie.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/boot/syslinux/0002-disable-pie.patch b/boot/syslinux/0002-disable-pie.patch
new file mode 100644
index 000000000..b31b622c4
--- /dev/null
+++ b/boot/syslinux/0002-disable-pie.patch
@@ -0,0 +1,22 @@
+Description: Disable PIE to avoid FTBFS on amd64
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/1579023
+Author: Graham Inggs <ginggs@ubuntu.com>
+Last-Update: 2016-05-06
+
+gcc 6.x has PIE support enabled by default, which causes a build issue
+with syslinux. This patch disables PIE support in the relevant
+syslinux Makefile.
+
+Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
+
+--- a/gpxe/src/Makefile
++++ b/gpxe/src/Makefile
+@@ -4,7 +4,7 @@
+ #
+
+ CLEANUP :=
+-CFLAGS :=
++CFLAGS := -fno-PIE
+ ASFLAGS :=
+ LDFLAGS :=
+ MAKEDEPS := Makefile