summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorCharles Hardin <ckhardin@exablox.com>2016-05-21 13:11:09 -0700
committerPeter Korsgaard <peter@korsgaard.com>2016-07-31 20:19:40 +0200
commitfc174b7057495ebb31393ae27f3ceeefdc490022 (patch)
tree76714d76718f3b55343ec26adcf65eb36c7a818e /boot
parent6b669897e0ce6d8b8064794ea2202c66e3ab2614 (diff)
grub2: fix build with BR2_STRIP_none
grub2 assumes the strip command will generate output and the output should always be stripped - so, just use the $(TARGET_CROSS)strip to make sure that the build succeeds regardless of the buildroot strip configuration. Signed-off-by: Charles Hardin <ckhardin@exablox.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/grub2/grub2.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index 112a401b0..dc4e51ea8 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -45,6 +45,9 @@ endif
# the confusion, it also uses NM, OBJCOPY and STRIP to build the
# bootloader itself; none of these are used to build the native
# tools.
+#
+# NOTE: TARGET_STRIP is overridden by BR2_STRIP_none, so always
+# use the cross compile variant to ensure grub2 builds
GRUB2_CONF_ENV = \
$(HOST_CONFIGURE_OPTS) \
@@ -55,7 +58,7 @@ GRUB2_CONF_ENV = \
TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
NM="$(TARGET_NM)" \
OBJCOPY="$(TARGET_OBJCOPY)" \
- STRIP="$(TARGET_STRIP)"
+ STRIP="$(TARGET_CROSS)strip"
GRUB2_CONF_OPTS = \
--target=$(GRUB2_TARGET) \