summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-09-02 16:20:33 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-09-02 16:20:33 +0200
commit7353967690b425fd6519756979f3ef839b1a9cd1 (patch)
treea910fd6b794556251fe607295c631aed98534235 /docs
parentcff53ce35b8dab3bbdd9aa4471d1ecb3238c9fab (diff)
parent1bd02bc230e1b3b22ca3eb23fb3dcb91b878283a (diff)
Merge branch 'next'
Quite some conflicts, so here goes .. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-asciidoc.txt5
-rw-r--r--docs/manual/adding-packages-generic.txt7
-rw-r--r--docs/manual/manual.mk3
3 files changed, 15 insertions, 0 deletions
diff --git a/docs/manual/adding-packages-asciidoc.txt b/docs/manual/adding-packages-asciidoc.txt
index 6e2178696..a278d44cc 100644
--- a/docs/manual/adding-packages-asciidoc.txt
+++ b/docs/manual/adding-packages-asciidoc.txt
@@ -63,6 +63,11 @@ information is (assuming the document name is +foo+) :
to one or more directories containing so-called resources (like CSS or
images). By default, empty.
+* +FOO_DEPENDENCIES+, optional, the list of packages (most probably,
+ host-packages) that must be built before building this document.
+ If a hook of your document needs to access the _Kconfig_ structure,
+ you may add +prepare-kconfig+ to the list of dependencies.
+
There are also additional hooks (see xref:hooks[] for general information
on hooks), that a document may set to define extra actions to be done at
various steps:
diff --git a/docs/manual/adding-packages-generic.txt b/docs/manual/adding-packages-generic.txt
index ef895ec91..51408e869 100644
--- a/docs/manual/adding-packages-generic.txt
+++ b/docs/manual/adding-packages-generic.txt
@@ -250,6 +250,13 @@ information is (assuming the package name is +libfoo+) :
+LIBFOO_SITE=/opt/software/libfoo.tar.gz+ +
+LIBFOO_SITE=$(TOPDIR)/../src/libfoo+
+* +LIBFOO_DL_OPTS+ is a space-separated list of additional options to
+ pass to the downloader. Useful for retrieving documents with
+ server-side checking for user logins and passwords, or to use a proxy.
+ All download methods valid for +LIBFOO_SITE_METHOD+ are supported;
+ valid options depend on the download method (consult the man page
+ for the respective download utilities).
+
* +LIBFOO_EXTRA_DOWNLOADS+ is a space-separated list of additional
files that Buildroot should download. If an entry contains +://+
then Buildroot will assume it is a complete URL and will download
diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index caf080a84..b26f91234 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -7,6 +7,9 @@
MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
MANUAL_RESOURCES = $(TOPDIR)/docs/images
+# Ensure the kconfig snippet is generated (for MANUAL_GEN_LISTS, below):
+MANUAL_DEPENDENCIES += prepare-kconfig
+
# Our manual needs to generate lists
define MANUAL_GEN_LISTS
$(Q)$(call MESSAGE,"Updating the manual lists...")