summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-03-11 18:41:09 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-19 16:41:22 +0100
commit84c825f8e893bfb56847ab4a880c46066a41744f (patch)
treee26ab28ab45e94ad09f6ab9ea4fef718d7fca69e /docs
parent5b96eb6703360778d0ed1002c2f102dac7c8229d (diff)
core: add the possibility to provide help for custom rules
When using a br2-external tree, it is possible (as stated in our manual) to implement whatever arbitrary extra make rules (such as flashing a board, or extracting the rootfs in an NFS export...). Some of those extra rules might be exposed to the user as new entry points that the user can call by itself. However, there is no way for the br2-external to advertise those new rules in the help text. We add the possibility to do so, by adding a new make rule, called help-custom, advertised in our own help info. It is up to the br2-external tree to provide whatever help text is deemed necessary. The format of the help is completely free-form. Note that we need to provide an empty, dummy help-custom rule, since it is always advertised (making it .PHONY does not work). Since this rule is empty, make gently reports that there is "Nothing to be done for `help-local'", which is pretty well fitting when help-local was not provided (either because there's no br2-external tree, or when the br2-external tree does not provide it. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Jérôme Pouiller <jezz@sysmic.org> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/customize-outside-br.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/docs/manual/customize-outside-br.txt b/docs/manual/customize-outside-br.txt
index 9ad177d00..be1827e6b 100644
--- a/docs/manual/customize-outside-br.txt
+++ b/docs/manual/customize-outside-br.txt
@@ -107,3 +107,17 @@ And then in +$(BR2_EXTERNAL)/package/package1+ and
output of +make list-defconfigs+ and allow them to be loaded with the
normal +make <name>_defconfig+ command. They will be visible under the
+User-provided configs+' label in the 'make list-defconfigs' output.
+
+Additionally, an +external.mk+ file may define the +help-custom+ make
+rule, to document custom make targets specific to this +BR2_EXTERNAL+
+tree. The help is completely free-form.
+
+------
+help-custom:
+ @echo 'Here goes your local help, where you may'
+ @echo 'describe some custom rules:'
+ @echo ' my-rule - do something'
+ @echo ' my-other-rule - do something else'
+ @echo
+ @echo 'Please contact support@company.com in case of problem.'
+------