summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-09-04 16:17:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-19 19:32:59 +0200
commitd4db4277ffbd1fae478ba748c626eddc7c220e67 (patch)
treed4898a777dd0098e8de7903170d1678b9c94f30c /docs
parent5676a2deea896f38123b99781da0a612865adeb0 (diff)
manual: get rid of the lists of packages
We currently have four lists of packages in the manual: - the non-virtual target packages, - the virtual target packages, - the host packages, - the deprecated features. Those list take more than half of the manual. They do not serve much purpose except to show off. After the recent discussion on the list [0], remove them all. We can now get rid of our biggish and complex generating script (and its companion library kconfiglib). [0] http://lists.busybox.net/pipermail/buildroot/2016-September/171199.html Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-virtual.txt6
-rw-r--r--docs/manual/appendix.txt37
-rw-r--r--docs/manual/manual.mk24
3 files changed, 0 insertions, 67 deletions
diff --git a/docs/manual/adding-packages-virtual.txt b/docs/manual/adding-packages-virtual.txt
index a5f17a262..6326bb545 100644
--- a/docs/manual/adding-packages-virtual.txt
+++ b/docs/manual/adding-packages-virtual.txt
@@ -83,9 +83,6 @@ On line 3, we select +BR2_PACKAGE_HAS_SOMETHING_VIRTUAL+, and on line 11, we
set the value of +BR2_PACKAGE_PROVIDES_SOMETHING_VIRTUAL+ to the name of the
provider, but only if it is selected.
-See xref:virtual-package-list[] for the symbols to select if you implement
-a new provider for an existing virtual package.
-
==== Provider's +.mk+ file
The +.mk+ file should also declare an additional variable
@@ -99,9 +96,6 @@ packages it is an implementation of:
Of course, do not forget to add the proper build and runtime dependencies for
this package!
-See xref:virtual-package-list[] for the names of virtual packages to provide
-if you implement a new provider for an existing virtual package.
-
==== Notes on depending on a virtual package
When adding a package that requires a certain +FEATURE+ provided by a virtual
diff --git a/docs/manual/appendix.txt b/docs/manual/appendix.txt
index 87a20bd86..03dbbd113 100644
--- a/docs/manual/appendix.txt
+++ b/docs/manual/appendix.txt
@@ -3,40 +3,3 @@
include::makedev-syntax.txt[]
include::makeusers-syntax.txt[]
-
-
-// Automatically generated lists:
-
-[[package-list]]
-== List of target packages available in Buildroot
-
-include::package-list.txt[]
-
-[[virtual-package-list]]
-== List of virtual packages
-
-These are the virtual packages known to +Buildroot+, with the
-corresponding symbols and providers.
-
-include::virtual-package-list.txt[]
-
-[[host-package-list]]
-== List of host utilities available in Buildroot
-
-The following packages are all available in the menu +Host utilities+.
-
-include::host-package-list.txt[]
-
-[[deprecated-list]]
-== Deprecated features
-
-The following features are marked as _deprecated_ in Buildroot due to
-them being either too old or unmaintained. They will be removed at
-some point, so stop using them.
-Each deprecated symbol in kconfig depends on a symbol
-+BR2_DEPRECATED_SINCE_xxxx_xx+, which provides an indication of when
-the feature can be removed: features will not be removed within the
-year following deprecation. For example, a symbol depending on
-+BR2_DEPRECATED_SINCE_2013_05+ can be removed from 2014.05 onwards.
-
-include::deprecated-list.txt[]
diff --git a/docs/manual/manual.mk b/docs/manual/manual.mk
index b26f91234..1d03b213d 100644
--- a/docs/manual/manual.mk
+++ b/docs/manual/manual.mk
@@ -7,28 +7,4 @@
MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
MANUAL_RESOURCES = $(TOPDIR)/docs/images
-# Ensure the kconfig snippet is generated (for MANUAL_GEN_LISTS, below):
-MANUAL_DEPENDENCIES += prepare-kconfig
-
-# Our manual needs to generate lists
-define MANUAL_GEN_LISTS
- $(Q)$(call MESSAGE,"Updating the manual lists...")
- $(Q)$(COMMON_CONFIG_ENV) \
- BR2_DEFCONFIG="" \
- TOPDIR=$(TOPDIR) \
- O=$(@D) \
- python -B $(TOPDIR)/support/scripts/gen-manual-lists.py
-endef
-MANUAL_POST_RSYNC_HOOKS += MANUAL_GEN_LISTS
-
-# Our list-generating script requires argparse
-define MANUAL_CHECK_LISTS_DEPS
- $(Q)if ! python -c "import argparse" >/dev/null 2>&1 ; then \
- echo "You need python with argparse on your host to generate" \
- "the list of packages in the manual"; \
- exit 1; \
- fi
-endef
-MANUAL_CHECK_DEPENDENCIES_HOOKS += MANUAL_CHECK_LISTS_DEPS
-
$(eval $(call asciidoc-document))