summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-05-10 15:39:46 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-05-11 10:51:06 +0200
commit1773a2a14216f3bbae7264600471f700c400552a (patch)
treec7dfe78a007a9ab74a53a761ed3a42c2fefd88bd /fs/common.mk
parentebb5692f358833e4fb6f3ed5f3075241d80c6667 (diff)
fs: use our own mkpasswd when creating users
Export PATH=$(BR_PATH) so that our own mkpasswd is found before any existing host-system one. Reported-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Samuel Martin <s.martin49@gmail.com> Tested-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 831365ef1..47199c753 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -83,7 +83,7 @@ ifneq ($$(ROOTFS_USERS_TABLES),)
cat $$(ROOTFS_USERS_TABLES) >> $(USERS_TABLE)
endif
printf '$(subst $(sep),\n,$(PACKAGES_USERS))' >> $(USERS_TABLE)
- $(TOPDIR)/support/scripts/mkusers $(USERS_TABLE) $(TARGET_DIR) >> $(FAKEROOT_SCRIPT)
+ PATH=$(BR_PATH) $(TOPDIR)/support/scripts/mkusers $(USERS_TABLE) $(TARGET_DIR) >> $(FAKEROOT_SCRIPT)
echo "$$(ROOTFS_$(2)_CMD)" >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)
$$(HOST_DIR)/usr/bin/fakeroot -- $$(FAKEROOT_SCRIPT)