summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-01-28 21:11:25 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-28 22:57:52 +0100
commit984524fda1f8260e258421f6676d522591f025da (patch)
treeb46715f49ffb06e74c3fae97593c7124b2eaa595 /fs/common.mk
parentbbb1e7ae218701b74c88ee8d1f9fde7c763df54e (diff)
fs: ensure $(TARGET_DIR_WARNING_FILE) is writable
If the Buildroot tree is read-only, then $(TARGET_DIR_WARNING_FILE) is copied read-only into target/ but we may want to remove it during the build process. This poses no real problem, since target/ itself is guaranteed to be writable, but for good measure, force $(TARGET_DIR_WARNING_FILE) to be writable itself. Reported-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 9f3262019..30e752470 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -83,7 +83,7 @@ endif
echo "$$(ROOTFS_$(2)_CMD)" >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)
$$(HOST_DIR)/usr/bin/fakeroot -- $$(FAKEROOT_SCRIPT)
- cp support/misc/target-dir-warning.txt $$(TARGET_DIR_WARNING_FILE)
+ $(INSTALL) -m 0644 support/misc/target-dir-warning.txt $$(TARGET_DIR_WARNING_FILE)
-@rm -f $$(FAKEROOT_SCRIPT) $$(FULL_DEVICE_TABLE)
ifneq ($$(ROOTFS_$(2)_COMPRESS_CMD),)
$$(ROOTFS_$(2)_COMPRESS_CMD) $$@ > $$@$$(ROOTFS_$(2)_COMPRESS_EXT)