summaryrefslogtreecommitdiff
path: root/fs/common.mk
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-02-14 10:55:06 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-14 21:09:04 +0100
commita24877586a566e052897e50e6a0c2f53cfb029f5 (patch)
tree86bca22d05bd97d9554511aa9a946c76b64e178a /fs/common.mk
parent6c5c08b854e4490697076ae3c5a9c587d8672c63 (diff)
Makefile: add support for top-level parallel make
To be able to use top-level parallel make we must not depend in a rule on the order of evaluation of the prerequisites, so instead of relyng on the left to right ordering of evaluation of the prerequisites add an explicit rule to describe the dependencies. Add explicit rules to describe the following dependency chain: $(TARGETS) -> target-finalize -> rootfs-* -> target-post-image Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 30e752470..d95c26ba5 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -64,7 +64,7 @@ ROOTFS_$(2)_COMPRESS_EXT = .xz
ROOTFS_$(2)_COMPRESS_CMD = $$(XZ) -9 -C crc32 -c
endif
-$$(BINARIES_DIR)/rootfs.$(1): $$(ROOTFS_$(2)_DEPENDENCIES)
+$$(BINARIES_DIR)/rootfs.$(1): target-finalize $$(ROOTFS_$(2)_DEPENDENCIES)
@$$(call MESSAGE,"Generating root filesystem image rootfs.$(1)")
$$(foreach hook,$$(ROOTFS_$(2)_PRE_GEN_HOOKS),$$(call $$(hook))$$(sep))
rm -f $$(FAKEROOT_SCRIPT)
@@ -95,7 +95,7 @@ rootfs-$(1)-show-depends:
rootfs-$(1): $$(BINARIES_DIR)/rootfs.$(1) $$(ROOTFS_$(2)_POST_TARGETS)
ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
-TARGETS += rootfs-$(1)
+TARGETS_ROOTFS += rootfs-$(1)
endif
endef