summaryrefslogtreecommitdiff
path: root/fs/cpio
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2013-11-07 00:12:35 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-11-11 00:37:03 +0100
commit13ae0075a94895c1b021d20905867ee5f354bd49 (patch)
treef0ca7caa50341ed6f4710d19412925ccd88526a6 /fs/cpio
parent3970ebf837aa7ac52528d3afc8c1701015a024b0 (diff)
uboot-tools: factor out common mkimage infrastructure
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs/cpio')
-rw-r--r--fs/cpio/cpio.mk15
1 files changed, 1 insertions, 14 deletions
diff --git a/fs/cpio/cpio.mk b/fs/cpio/cpio.mk
index e39e21555..771306ced 100644
--- a/fs/cpio/cpio.mk
+++ b/fs/cpio/cpio.mk
@@ -31,21 +31,8 @@ define ROOTFS_CPIO_CMD
cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $@
endef
-# mkimage supports arm avr32 blackfin m68k microblaze mips mips64 nios2 powerpc ppc sh sparc sparc64 x86
-# KERNEL_ARCH can be arm64 arc arm avr32 blackfin m68k microblaze mips nios2 powerpc sh sparc i386 x86_64 xtensa
-# For arm64, arc, xtensa we'll just keep KERNEL_ARCH
-# For mips64, we'll just keep mips
-# For i386 and x86_64, we need to convert
-ifeq ($(KERNEL_ARCH),x86_64)
-UIMAGE_ARCH = x86
-else ifeq ($(KERNEL_ARCH),i386)
-UIMAGE_ARCH = x86
-else
-UIMAGE_ARCH = $(KERNEL_ARCH)
-endif
-
$(BINARIES_DIR)/rootfs.cpio.uboot: $(BINARIES_DIR)/rootfs.cpio host-uboot-tools
- $(HOST_DIR)/usr/bin/mkimage -A $(UIMAGE_ARCH) -T ramdisk \
+ $(MKIMAGE) -A $(MKIMAGE_ARCH) -T ramdisk \
-C none -d $<$(ROOTFS_CPIO_COMPRESS_EXT) $@
ifeq ($(BR2_TARGET_ROOTFS_CPIO_UIMAGE),y)