summaryrefslogtreecommitdiff
path: root/fs/ext2
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-12 18:37:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-14 10:12:32 +0200
commit2aef771f6e05d3fd1ea59c2faab986eaa55f28f7 (patch)
tree67047258ad2172dd4461df6f0f7d2141564c98fa /fs/ext2
parentf1e843864f89b58f806af371e0a09b1c219c522e (diff)
fs: declare phony targets as such
This commit improves the filesystem handling code to declare its various targets as PHONY when appropriate. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'fs/ext2')
-rw-r--r--fs/ext2/ext2.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index 1cac72e0d..cab66a5e2 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -35,6 +35,8 @@ endef
rootfs-ext2-symlink:
ln -sf rootfs.ext2$(ROOTFS_EXT2_COMPRESS_EXT) $(BINARIES_DIR)/rootfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN)$(ROOTFS_EXT2_COMPRESS_EXT)
+.PHONY: rootfs-ext2-symlink
+
ifneq ($(BR2_TARGET_ROOTFS_EXT2_GEN),2)
ROOTFS_EXT2_POST_TARGETS += rootfs-ext2-symlink
endif