summaryrefslogtreecommitdiff
path: root/fs/tar
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-02-16 18:49:16 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-19 22:02:59 +0100
commit66ee6dc8721ce8746a8352f02f52663b90887c63 (patch)
tree825970b10d5d8b935325a624729e46da5ab368d6 /fs/tar
parentf290046f66b714e9e4670e85e618c72f11745ca2 (diff)
fs/tar: only store numeric uid/gid
If a target user is asigned a UID (e.g. 1000) that happens to also exist on the build machine, tar will happily store the username for that user. This can be seen by some as potential information disclosure. Instruct tar to just store the numeric uid/gid. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/tar')
-rw-r--r--fs/tar/tar.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/tar/tar.mk b/fs/tar/tar.mk
index 780827e42..28219cf05 100644
--- a/fs/tar/tar.mk
+++ b/fs/tar/tar.mk
@@ -7,7 +7,7 @@
TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
define ROOTFS_TAR_CMD
- tar -c$(TAR_OPTS)f $@ -C $(TARGET_DIR) .
+ tar -c$(TAR_OPTS)f $@ --numeric-owner -C $(TARGET_DIR) .
endef
$(eval $(call ROOTFS_TARGET,tar))