summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-06-06 22:43:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-07 22:21:08 +0200
commit2e725848c3b33e6b2045b96b1088c0ea41cbd4bf (patch)
tree7e0b90f3b2ed3d038415bb74ca2d6c7f612a56f5 /fs
parent6dd7bbb59134799ed3d7343f238b3b02592faebf (diff)
fs/jffs2: split commands
Now that we can properly printf a multi-line command, there is no need to use a single command to gnerate the jffs2 image. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/jffs2/jffs2.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/fs/jffs2/jffs2.mk b/fs/jffs2/jffs2.mk
index a9cd4146e..9a36a75ff 100644
--- a/fs/jffs2/jffs2.mk
+++ b/fs/jffs2/jffs2.mk
@@ -39,8 +39,8 @@ ROOTFS_JFFS2_DEPENDENCIES = host-mtd
ifneq ($(BR2_TARGET_ROOTFS_JFFS2_SUMMARY),)
define ROOTFS_JFFS2_CMD
- $(MKFS_JFFS2) $(JFFS2_OPTS) -d $(TARGET_DIR) -o $@.nosummary && \
- $(SUMTOOL) $(SUMTOOL_OPTS) -i $@.nosummary -o $@ && \
+ $(MKFS_JFFS2) $(JFFS2_OPTS) -d $(TARGET_DIR) -o $@.nosummary
+ $(SUMTOOL) $(SUMTOOL_OPTS) -i $@.nosummary -o $@
rm $@.nosummary
endef
else