summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-12-14 23:28:10 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-12-14 23:45:48 +0100
commit5b272e3e551e723bae78140f7de4029b9026d961 (patch)
treeabedff57c9ec5fb9f19eed048f3a7ad7068afaf8 /fs
parentc583c421c4a76706f9956be01b7f5775999d61d6 (diff)
fs: set packages permissions even with no system device tables
Currently, when there is no syztem device table (permissions or static devices) defined, then package permissions are not applied, because they are guarded by the check on the system device tables being non empty. Fix that by narrowing the guarding condition. Note that the dependency on host-makedevs was not conditional; we always build it even if we don't need it. Making it conditional is not possible, because we don't know all the packages permissions by the time the fs infra is parsed (packages from br2-external are parsed after it). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 7515fdc77..396b1c2bd 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -89,9 +89,9 @@ ifneq ($$(ROOTFS_DEVICE_TABLES),)
ifeq ($$(BR2_ROOTFS_DEVICE_CREATION_STATIC),y)
$$(call PRINTF,$$(PACKAGES_DEVICES_TABLE)) >> $$(FULL_DEVICE_TABLE)
endif
+endif
$$(call PRINTF,$$(PACKAGES_PERMISSIONS_TABLE)) >> $$(FULL_DEVICE_TABLE)
echo "$$(HOST_DIR)/usr/bin/makedevs -d $$(FULL_DEVICE_TABLE) $$(TARGET_DIR)" >> $$(FAKEROOT_SCRIPT)
-endif
$$(foreach s,$$(call qstrip,$$(BR2_ROOTFS_POST_FAKEROOT_SCRIPT)),\
echo "echo '$$(TERM_BOLD)>>> Executing fakeroot script $$(s)$$(TERM_RESET)'" >> $$(FAKEROOT_SCRIPT); \
echo $$(s) $$(TARGET_DIR) $$(BR2_ROOTFS_POST_SCRIPT_ARGS) >> $$(FAKEROOT_SCRIPT)$$(sep))