summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2016-11-23 13:58:47 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-23 22:59:21 +0100
commit68db7210fd8e76120c27cdc4a1fe591de67c06c2 (patch)
treef2d34f8b4f820164cccaee336939b164bf116286 /fs
parenta8254d32fd839ebd0a96863579832678eb6e0038 (diff)
fs/common: lock modification times in $TARGET_DIR
Make sure all files in $TARGET_DIR have a defined modification time before to generate filesystems. This work was sponsored by `BA Robotic Systems'. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 2dbef4d7b..981dcb1aa 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -95,6 +95,9 @@ endif
$$(foreach s,$$(call qstrip,$$(BR2_ROOTFS_POST_FAKEROOT_SCRIPT)),\
echo "echo '$$(TERM_BOLD)>>> Executing fakeroot script $$(s)$$(TERM_RESET)'" >> $$(FAKEROOT_SCRIPT); \
echo $$(s) $$(TARGET_DIR) $$(BR2_ROOTFS_POST_SCRIPT_ARGS) >> $$(FAKEROOT_SCRIPT)$$(sep))
+ifeq ($$(BR2_REPRODUCIBLE),y)
+ echo "find $$(TARGET_DIR) -print0 | xargs -0 -r touch -hd @$$(SOURCE_DATE_EPOCH)" >> $$(FAKEROOT_SCRIPT)
+endif
$$(call PRINTF,$$(ROOTFS_$(2)_CMD)) >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)
PATH=$$(BR_PATH) $$(HOST_DIR)/usr/bin/pseudo -- $$(FAKEROOT_SCRIPT)