summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2016-06-24 11:57:56 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-25 15:42:44 +0200
commit6ae48ae3af9840a0b09d0cf0d6b07b2435910eaa (patch)
treea1b7b2520bd47c70c04061e966543d57e50509f6 /fs
parent9a55b996651fdfbc40e202cb4dd725dce624ca91 (diff)
fs/tar: support passing long options to tar
Move TAR_OPTS so that long options (or any option with an initial '-') may be passed to tar. Since TAR_OPTS is at the front of the list, single letter options still work. Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/tar/tar.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/tar/tar.mk b/fs/tar/tar.mk
index 28219cf05..11c69c5a8 100644
--- a/fs/tar/tar.mk
+++ b/fs/tar/tar.mk
@@ -7,7 +7,7 @@
TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
define ROOTFS_TAR_CMD
- tar -c$(TAR_OPTS)f $@ --numeric-owner -C $(TARGET_DIR) .
+ tar $(TAR_OPTS) -cf $@ --numeric-owner -C $(TARGET_DIR) .
endef
$(eval $(call ROOTFS_TARGET,tar))