summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-11-27 21:13:54 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-11-27 21:24:10 +0100
commit79061fe52f9cf5925f603d938feddfe41aab340e (patch)
treea78b594adcb7c9e8577ec18692438ba9bbbfea49 /fs
parent6d3e05690f3ecfdd1512393f7afd67e0042d05f0 (diff)
Revert "fs: use pseudo instead of fakeroot"
This reverts commit 8035ceb56cc3ba2541aba0d0ead3f29900d9e310. Moving to pseudo brought a number of issues (and longer compilation time), so lets stick with fakeroot now that the reported ubi issue has been worked around. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/common.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 2dbef4d7b..2b31e1293 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -43,7 +43,7 @@ ROOTFS_USERS_TABLES = $(call qstrip,$(BR2_ROOTFS_USERS_TABLES))
define ROOTFS_TARGET_INTERNAL
# extra deps
-ROOTFS_$(2)_DEPENDENCIES += host-pseudo host-makedevs \
+ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs \
$$(if $$(PACKAGES_USERS)$$(ROOTFS_USERS_TABLES),host-mkpasswd)
ifeq ($$(BR2_TARGET_ROOTFS_$(2)_GZIP),y)
@@ -97,7 +97,7 @@ endif
echo $$(s) $$(TARGET_DIR) $$(BR2_ROOTFS_POST_SCRIPT_ARGS) >> $$(FAKEROOT_SCRIPT)$$(sep))
$$(call PRINTF,$$(ROOTFS_$(2)_CMD)) >> $$(FAKEROOT_SCRIPT)
chmod a+x $$(FAKEROOT_SCRIPT)
- PATH=$$(BR_PATH) $$(HOST_DIR)/usr/bin/pseudo -- $$(FAKEROOT_SCRIPT)
+ PATH=$$(BR_PATH) $$(HOST_DIR)/usr/bin/fakeroot -- $$(FAKEROOT_SCRIPT)
$$(INSTALL) -m 0644 support/misc/target-dir-warning.txt $$(TARGET_DIR_WARNING_FILE)
-@rm -f $$(FAKEROOT_SCRIPT) $$(FULL_DEVICE_TABLE)
ifneq ($$(ROOTFS_$(2)_COMPRESS_CMD),)