summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorNoé Rubinstein <noe.rubinstein@gmail.com>2015-07-30 16:47:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-30 23:31:26 +0200
commit8fb2b4c9daf00bcba3d6626f19c21f52675ce6b0 (patch)
tree60a0ea13f04c169d28686957b047b6e7f133f30b /fs
parent4feec7405f2284e1bb468751e663574c28db4d1d (diff)
fs/iso9660: install Isolinux comboot modules
This installs every module selected by the BR2_TARGET_SYSLINUX_C32. This is useful when using a custom Isolinux configuration file that may use comboot modules. Signed-off-by: Noé Rubinstein <nrubinstein@aldebaran.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/iso9660/iso9660.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index d83619462..32d79d77d 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -68,8 +68,8 @@ ROOTFS_ISO9660_BOOTLOADER_CONFIG_PATH = \
$(ROOTFS_ISO9660_TARGET_DIR)/isolinux/isolinux.cfg
ROOTFS_ISO9660_BOOT_IMAGE = isolinux/isolinux.bin
define ROOTFS_ISO9660_INSTALL_BOOTLOADER
- $(INSTALL) -D -m 0644 $(BINARIES_DIR)/syslinux/isolinux.bin \
- $(ROOTFS_ISO9660_TARGET_DIR)/isolinux/isolinux.bin
+ $(INSTALL) -D -m 0644 $(BINARIES_DIR)/syslinux/* \
+ $(ROOTFS_ISO9660_TARGET_DIR)/isolinux/
$(INSTALL) -D -m 0644 $(HOST_DIR)/usr/share/syslinux/ldlinux.c32 \
$(ROOTFS_ISO9660_TARGET_DIR)/isolinux/ldlinux.c32
endef