summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2016-12-27 19:42:03 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-12-28 10:13:21 +0100
commitd91ce1aa08016fa3fb186be9e6ef425dad6f050f (patch)
treee41cd6812b1f9e3cd9a2814243dbc420ada57eaa /fs
parent0e3526c10e80822b0a25b7171ced77c9cc1d9121 (diff)
fs/tar: make --no-recursion effective
The tar --no-recursion option is position sensitive. It only affects following file listing options. Move --no-recursion before the -T option to make it effective. This fixes duplication of entries in the generated rootfs.tar archive. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/tar/tar.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/tar/tar.mk b/fs/tar/tar.mk
index b14c977d7..0e3eacbed 100644
--- a/fs/tar/tar.mk
+++ b/fs/tar/tar.mk
@@ -8,7 +8,7 @@ TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
define ROOTFS_TAR_CMD
(cd $(TARGET_DIR); find -print0 | LC_ALL=C sort -z | \
- tar $(TAR_OPTS) -cf $@ --null -T - --no-recursion --numeric-owner)
+ tar $(TAR_OPTS) -cf $@ --null --no-recursion -T - --numeric-owner)
endef
$(eval $(call ROOTFS_TARGET,tar))