summaryrefslogtreecommitdiff
path: root/linux/linux-ext-ev3dev-linux-drivers.mk
diff options
context:
space:
mode:
authorDavid Lechner <david@lechnology.com>2016-11-01 22:15:55 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-02 17:52:24 +0100
commit7d4a2f2ca43eb6b925cdf5b6b15d48ac49ee96af (patch)
tree03a01c0b2423738e409dda76082fb2e6dd6740a4 /linux/linux-ext-ev3dev-linux-drivers.mk
parentc846d2e21133441e92b1ee3b98f2fc013a01db16 (diff)
linux: add ev3dev extension
This adds an ev3dev Linux drivers extension that provides Linux kernel drivers for LEGO MINDSTORMS EV3 from the ev3dev project. Signed-off-by: David Lechner <david@lechnology.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux-ext-ev3dev-linux-drivers.mk')
-rw-r--r--linux/linux-ext-ev3dev-linux-drivers.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/linux/linux-ext-ev3dev-linux-drivers.mk b/linux/linux-ext-ev3dev-linux-drivers.mk
new file mode 100644
index 000000000..c8afeeb1d
--- /dev/null
+++ b/linux/linux-ext-ev3dev-linux-drivers.mk
@@ -0,0 +1,12 @@
+################################################################################
+# Linux ev3dev extensions
+#
+# Patch the linux kernel with ev3dev extension
+################################################################################
+
+LINUX_EXTENSIONS += ev3dev-linux-drivers
+
+define EV3DEV_LINUX_DRIVERS_PREPARE_KERNEL
+ mkdir -p $(LINUX_DIR)/drivers/lego
+ cp -dpfr $(EV3DEV_LINUX_DRIVERS_DIR)/* $(LINUX_DIR)/drivers/lego/
+endef