summaryrefslogtreecommitdiff
path: root/linux/linux-ext-rtai.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-03-14 15:25:21 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-09 23:00:01 +0200
commit700be8e2a48963e67e44088bcf5a17e92d92e6b7 (patch)
tree608d94b0e75a679c55a4dd15098b81d410234076 /linux/linux-ext-rtai.mk
parent9bd541d3b2a0256d59bc84fb2d204401dcdedb8e (diff)
linux: migrate extensions to use the new infrastructure
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux-ext-rtai.mk')
-rw-r--r--linux/linux-ext-rtai.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/linux/linux-ext-rtai.mk b/linux/linux-ext-rtai.mk
index 942b43038..07e7a19cd 100644
--- a/linux/linux-ext-rtai.mk
+++ b/linux/linux-ext-rtai.mk
@@ -4,9 +4,7 @@
# Patch the linux kernel with RTAI extension
################################################################################
-ifeq ($(BR2_LINUX_KERNEL_EXT_RTAI),y)
-# Add dependency to RTAI (user-space) which provide kernel patches
-LINUX_PATCH_DEPENDENCIES += rtai
+LINUX_EXTENSIONS += rtai
RTAI_PATCH = $(call qstrip,$(BR2_LINUX_KERNEL_EXT_RTAI_PATCH))
@@ -41,7 +39,3 @@ define RTAI_PREPARE_KERNEL
$(notdir $(RTAI_PATCH))
endef
endif
-
-LINUX_PRE_PATCH_HOOKS += RTAI_PREPARE_KERNEL
-
-endif #BR2_LINUX_EXT_RTAI