summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-10-04 20:12:41 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-10-04 20:17:35 +0200
commitab74e09eb4e28dab8bed8d783c5f0464d39a32e7 (patch)
tree7f46df86b3c8850390013054ea24784d7f6469c5 /linux/linux.mk
parentfd47f22bc09b46380c25ccf31abff4167b48831e (diff)
linux: install dtc binary as linux-dtc
So it doesn't conflict with host-dtc. The Linux kernel version may be a patched version supporting E.G. overlays. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 231957628..c98459f33 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -294,7 +294,7 @@ endif
define LINUX_INSTALL_HOST_TOOLS
# Installing dtc (device tree compiler) as host tool, if selected
if grep -q "CONFIG_DTC=y" $(@D)/.config; then \
- $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/dtc ; \
+ $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/linux-dtc ; \
fi
endef