summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-09-03 14:54:19 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-09-04 13:13:52 +0200
commitb7c32c98bc810b88e0391117f225658f82b44995 (patch)
tree00cfa6903c17b39cd24480726183bb59594ca8cc /linux/linux.mk
parentf07da1a5987d881f7133d664776d3cb8a85cc570 (diff)
core/pkg-kernel-module: ensure linux supports modules
When a package wants to build a kernel module, we should ensure that the kernel does support modules. This patch does it automatically for packages using the kernel-module infrastructure. Packages that do not use it will have to set it manually (to be done in a followup patch). Suggested-by: Peter Korsgaard <jacmet@uclibc.org> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: NoƩ Rubinstein <noe.rubinstein@gmail.com> Cc: Jan Viktorin <viktorin@rehivetech.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 48f9c740f..bbcc54bfd 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -175,6 +175,8 @@ LINUX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
LINUX_KCONFIG_OPTS = $(LINUX_MAKE_FLAGS)
define LINUX_KCONFIG_FIXUP_CMDS
+ $(if $(LINUX_NEEDS_MODULES),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_MODULES,$(@D)/.config))
$(if $(BR2_arm)$(BR2_armeb),
$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config))
$(if $(BR2_TARGET_ROOTFS_CPIO),