summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-08-21 23:58:29 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-23 21:01:51 +0200
commitd824792b75475719949850179f08ad8ec8d0a228 (patch)
treeb8057bcd31a423ca8d7fbf72fd382219e855dabd /linux/linux.mk
parent8c1bff77f47f3d031b8f9471fdf4fa8c2da4a8c7 (diff)
linux: enable all options needed by xtables-addons
Both of CONFIG_NF_CONNTRACK and CONFIG_NF_CONNTRACK_MARK are needed by xtables-addons. Although the current code does enable them in the linux' .config file, the former is protected behind CONFIG_NETFILTER_ADVANCED, which may be missing from a user-supplied (def)config file, and is missing from some of the bundled defconfigs as well. For example, the following defconfig fails to build: BR2_TOOLCHAIN_EXTERNAL=y BR2_LINUX_KERNEL=y BR2_LINUX_KERNEL_DEFCONFIG="i386" BR2_PACKAGE_XTABLES_ADDONS=y So, also force-enable CONFIG_NETFILTER_ADVANCED. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index d91dbb2df..48f9c740f 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -215,6 +215,7 @@ define LINUX_KCONFIG_FIXUP_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES,$(@D)/.config))
$(if $(BR2_PACKAGE_XTABLES_ADDONS),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_ADVANCED,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),