summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2016-02-02 00:38:11 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-02 10:20:46 +0100
commitda4fff547c4c55926cf0c62cf1ebb6a59d5e0347 (patch)
tree0be0c3fcb44ce7353c936a30748f5d4140899415 /linux/linux.mk
parent63abfb7210313fcc84b912ff2884b1357beff4b5 (diff)
kernel-module-imx-gpu-viv: add new package
This is the Vivante kernel driver split from the kernel source code in order to make it possible to be used in any kernel source since 3.10.53. The driver source code provided by Freescale needs fixes so the community forked the code to allow faster development and easier integration of fixes from the community. This patch is based on the Yocto equivalent: https://github.com/Freescale/meta-fsl-arm/commit/32cf391 https://github.com/Freescale/meta-fsl-arm/commit/4249193 This package has been tested with the following commands: # modprobe galcore # cd /usr/share/examples/viv_samples/vdk/ # ./tutorial7 Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 3c53a0bc0..c9986cd8a 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -251,6 +251,8 @@ define LINUX_KCONFIG_FIXUP_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
+ $(if $(BR2_PACKAGE_KERNEL_MODULE_IMX_GPU_VIV),
+ $(call KCONFIG_DISABLE_OPT,CONFIG_MXC_GPU_VIV,$(@D)/.config))
endef
ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT),y)