summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorChristian Kellermann <christian.kellermann@solectrix.de>2016-12-12 12:27:37 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-17 15:55:32 +0100
commit93f31b20da05a9d7a99c47a8a3dfe1a6f4ffe203 (patch)
tree815b44ff0d3371c3774c7c3ee52ae125a96d4019 /linux
parentddd108f39f1b369ad20d897f2340f7a50e5658b7 (diff)
linux: check that a repo and version is defined when using a custom repo
If not set the system will use an empty string which will result in download errors for 'linux-.tar.gz' packages. This patch makes it obvious to the user that the variable needs to be set. Signed-off-by: Christian Kellermann <christian.kellermann@solectrix.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index e75dcaa60..7f4432e7b 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -428,6 +428,17 @@ LINUX_PRE_PATCH_HOOKS += $(foreach ext,$(LINUX_EXTENSIONS),\
$(call UPPERCASE,$(ext))_PREPARE_KERNEL))
# Checks to give errors that the user can understand
+
+# When a custom repository has been set, check for the repository version
+ifeq ($(BR2_LINUX_KERNEL_CUSTOM_SVN)$(BR2_LINUX_KERNEL_CUSTOM_GIT)$(BR2_LINUX_KERNEL_CUSTOM_HG),y)
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION)),)
+$(error No custom repository version set. Check your BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION setting)
+endif
+ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL)),)
+$(error No custom repo URL set. Check your BR2_LINUX_KERNEL_CUSTOM_REPO_URL setting)
+endif
+endif
+
ifeq ($(BR_BUILDING),y)
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)