summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-30 18:10:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-30 18:10:18 +0200
commit255b6f80d395ef048f46cfcf75dba690c56af657 (patch)
treedd10c2855a9b20dd386257dc665124edd8a26707 /package/Makefile.in
parent0340ce3cb7b8c3b57a272fa256b4661dde961e36 (diff)
Revert "package/Makefile.in should grab HOST_DIR headers using -isystem instead of -I."
This reverts commit 6f8162cf8c1abef7e0a4771fe0d6b26a28f5c2b6. This is causing too many problems that are not easy to solve. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index b0ef70676..afd5d3a59 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -222,7 +222,7 @@ UNZIP := $(shell which unzip || type -p unzip) -q
APPLY_PATCHES = support/scripts/apply-patches.sh $(if $(QUIET),-s)
-HOST_CPPFLAGS = -isystem $(HOST_DIR)/usr/include
+HOST_CPPFLAGS = -I$(HOST_DIR)/usr/include
HOST_CFLAGS ?= -O2
HOST_CFLAGS += $(HOST_CPPFLAGS)
HOST_CXXFLAGS += $(HOST_CFLAGS)