summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorAxel Lin <axel.lin@ingics.com>2013-09-23 17:16:50 +0800
committerPeter Korsgaard <peter@korsgaard.com>2014-10-12 14:58:54 +0200
commit3c25f6e6c0a57daac4786dbdf2f0242273641566 (patch)
tree5e193c34eab4904a2003aaed8b341ecf9480bb45 /package/Makefile.in
parent526e3d0ac6641c0a969d08f5839aa7b12b0dba9a (diff)
package/Makefile.in: Fix dependency for selecting uclinux as TARGET_OS
Current setting only allows blackfin to select uclinux as TARGET_OS. However, some noMMU ARM platforms that using FLAT binary format also need to select uclinux as TARGET_OS. Fix the dependency. Signed-off-by: Axel Lin <axel.lin@ingics.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 7d9943c1c..28a5bfdfc 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -38,8 +38,8 @@ endif
# Compute GNU_TARGET_NAME
GNU_TARGET_NAME = $(ARCH)-$(TARGET_VENDOR)-$(TARGET_OS)-$(LIBC)$(ABI)
-# Blackfin FLAT needs uclinux
-ifeq ($(BR2_bfin)$(BR2_BINFMT_FLAT),yy)
+# FLAT binary format needs uclinux
+ifeq ($(BR2_BINFMT_FLAT),y)
TARGET_OS = uclinux
else
TARGET_OS = linux