summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorMartin Kelly <martin@surround.io>2016-05-18 14:17:55 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-24 23:17:52 +0200
commit5ff845927b3559d29f0b9d751e1ac6106201d4c9 (patch)
treef78097044f5a38c0f30a873a88075e8d88c91cc7 /package/Makefile.in
parent86409e1a4bc94ef6754a31b48561b72fad352f36 (diff)
Config.in: add -Og option
-Og (introduced in GCC 4.8) lets you optimize for debugging experience, which can be useful for when you want optimized code that is nonetheless debuggable. Signed-off-by: Martin Kelly <martin@surround.io> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 616bdd056..2d454a638 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -122,6 +122,9 @@ endif
ifeq ($(BR2_OPTIMIZE_3),y)
TARGET_OPTIMIZATION = -O3
endif
+ifeq ($(BR2_OPTIMIZE_G),y)
+TARGET_OPTIMIZATION = -Og
+endif
ifeq ($(BR2_OPTIMIZE_S),y)
TARGET_OPTIMIZATION = -Os
endif