summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-31 21:00:11 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-04-08 14:27:59 +0200
commit6da05ab150a2321835f2317911b8b79b9da06625 (patch)
tree878b470047f6a96a9620882c114a5b7930ab87e0 /package/Makefile.in
parentee47352920cd0a89d6b775d489541183b31fb9d1 (diff)
package/Makefile.in: adjust LDFLAGS for elf2flt
So far, our LDFLAGS for the BR2_BINFMT_FLAT case were only used on Blackfin. However, passing -elf2flt in LDFLAGS is wrong. Indeed, LDFLAGS are not linker flags, but flags passed to the compiler when linking. If you pass -elf2flt to the compiler when linking, it is understood as "-e lf2flt", i.e "the entry point is named lf2flt", which isn't exactly the intention. We in fact need to pass -Wl,-elf2flt in LDFLAGS as well, so that the compiler passes -elf2flt down to the linker. For some reason, this option does not cause an issue with the Blackfin toolchain, but it does with either a Buildroot toolchain for Cortex-M or an OSELAS toolchain for Cortex-M. We have verified that passing -Wl,-elf2flt continues to work with the Blackfin toolchain. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index dd595e2b7..616bdd056 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -145,7 +145,7 @@ TARGET_CFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt=-s$($(PKG)_FL
-Wl$(comma)-elf2flt)
TARGET_CXXFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt=-s$($(PKG)_FLAT_STACKSIZE),\
-Wl$(comma)-elf2flt)
-TARGET_LDFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-elf2flt=-s$($(PKG)_FLAT_STACKSIZE),-elf2flt)
+TARGET_LDFLAGS += $(if $($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt=-s$($(PKG)_FLAT_STACKSIZE),-Wl$(comma)-elf2flt)
endif
ifeq ($(BR2_BINFMT_FLAT_SHARED),y)