summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-07-12 02:21:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-12 11:56:18 +0200
commit8b525dc934f18631a42e34d010530b9217d390f3 (patch)
tree7ee5bd0261db865ff96014e8ebc185cd6e9aa21e /package/Makefile.in
parent628de86c996c77d9d66acf33d93384faccc59a3e (diff)
package-infra: add helper to build kernel modules
The Linux kernel offers a nice and easy-to-use infra to build out-of-tree kernel modules. Currently, we have quite a few packages that build kernel modules, and most duplicate (or rewrite) the same code over-and-over again. Introduce a new infrastructure that provides helpers to build kernel modules, so packages do not have to duplicate/rewrite that. The infrastructure, unlike any other package infra, is not standalone. It needs another package infra to be used. This is so that packages that provide both userland and kernel modules can be built easily. So, this infra only defines post-build and post-install hooks, that will build the kernel modules after the rest of the package. We need to override PWD, because some packages will use it to find their own includes (and other helper files). PWD is inherited from the environment, so it gets whatever value it had when make was launched, which happens to be Buildroot's own top source tree. So, we just force PWD to the proper value, rather than cd-ing first. Also, no host version is provided, since it does not make sense to build kernel modules for the host. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Baruch Siach <baruch@tkos.co.il> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 2ed7cf7d2..545694f38 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -399,3 +399,4 @@ include package/pkg-virtual.mk
include package/pkg-generic.mk
include package/pkg-kconfig.mk
include package/pkg-rebar.mk
+include package/pkg-kernel-module.mk