summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-12-04 22:37:24 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-12-06 20:40:10 +0100
commit90605b8fe72e61ad8224b7f5c2dde7a5dedbf791 (patch)
tree4b6e127af154b443f4f0085343004c5359dc827c /package/Makefile.in
parent34d34e13058d75875e7a90ca1866133fbaeb0c6e (diff)
Makefile: move SED definition into the main Makefile
Since commit f71a621d91ec27f175fc84012962f88b1107305f, we are using the SED variable in the main Makefile. However, this variable is only defined in package/Makefile.in, which gets included only when a configuration is defined. This means that, if you do: $ make menuconfig savedefconfig without a configuration defined, it fails with: /bin/bash: /BR2_DEFCONFIG=/d: No such file or directory Makefile:898: recipe for target 'savedefconfig' failed make[1]: *** [savedefconfig] Error 127 This issue affects users of the "buildroot-submodule" project, which does menuconfig+savedefconfig automatically. They worked around this issue in commit https://github.com/Openwide-Ingenierie/buildroot-submodule/commit/d12676b608a58529c6b551aa176464166a200428, but really "make menuconfig savedefconfig" should work out of the box. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 4b3368f49..688d5b161 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -213,7 +213,6 @@ endif
INSTALL := $(shell which install || type -p install)
FLEX := $(shell which flex || type -p flex)
BISON := $(shell which bison || type -p bison)
-SED := $(shell which sed || type -p sed) -i -e
UNZIP := $(shell which unzip || type -p unzip) -q
APPLY_PATCHES = support/scripts/apply-patches.sh $(if $(QUIET),-s)