summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2015-10-04 16:23:56 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-10-04 18:22:20 +0200
commitd82f69cf100c51cc65c9fb27132517dd3efd554a (patch)
treef08ffe5e2b0bb979ade4aa98ff82a2e81c64035b /package/Makefile.in
parent2f8dc29c1d9f2adda850dead5325e422715d251e (diff)
infra: move ccache handling to the toolchain wrapper
Since we always have a toolchain wrapper now, we can move the ccache call to the toolchain wrapper. The hostcc ccache handling obviously stays. The global addition of ccache to TARGET_CC/CXX is removed, but many individual packages and infras still add it. This means we have a chain like this: ccache -> toolchain-wrapper -> ccache -> gcc However, this is fairly harmless: for cache misses, the inner ccache just adds overhead and for cache hits, the inner ccache is never called. Later patches will remove these redundant ccache calls. As a side effect, perl now supports ccache as well. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Cc: Danomi Manchego <danomimanchego123@gmail.com> Cc: Károly Kasza <kaszak@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in5
1 files changed, 0 insertions, 5 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 545694f38..4b1ce7fae 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -189,11 +189,6 @@ TARGET_OBJDUMP = $(TARGET_CROSS)objdump
TARGET_CC_NOCCACHE := $(TARGET_CC)
TARGET_CXX_NOCCACHE := $(TARGET_CXX)
-ifeq ($(BR2_CCACHE),y)
-TARGET_CC := $(CCACHE) $(TARGET_CC)
-TARGET_CXX := $(CCACHE) $(TARGET_CXX)
-endif
-
ifeq ($(BR2_STRIP_strip),y)
STRIP_STRIP_DEBUG := --strip-debug
STRIP_STRIP_UNNEEDED := --strip-unneeded