summaryrefslogtreecommitdiff
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-11-07 02:19:56 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-09 22:50:53 +0100
commite4e2cc4d4b0cc4ad1fafa208e1c6887452727a4e (patch)
treecd34f7bcb6d2f1294cb4d5215a68cb3735440e47 /package/Makefile.in
parent00e7d119ec16cd64f89cb21a2ea715e2bfc3dc73 (diff)
Use already qstripped BR2_TOOLCHAIN_EXTERNAL_PREFIX everywhere
The BR2_TOOLCHAIN_EXTERNAL_PREFIX variable is already qstripped and stored in the TOOLCHAIN_EXTERNAL_PREFIX variable in toolchain-external.mk, so use this variable everywhere. This will be useful for a later patch that makes the derivation of TOOLCHAIN_EXTERNAL_PREFIX a little more complex. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Romain Naour <romain.naour@gmail.com> [Arnout: split off into separate patch] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 5d591e9a4..bd73219bb 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -184,7 +184,7 @@ endif
ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
TARGET_CROSS = $(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-
else
-TARGET_CROSS = $(HOST_DIR)/usr/bin/$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))-
+TARGET_CROSS = $(HOST_DIR)/usr/bin/$(TOOLCHAIN_EXTERNAL_PREFIX)-
endif
# Define TARGET_xx variables for all common binutils/gcc