summaryrefslogtreecommitdiff
path: root/package/a10disp
diff options
context:
space:
mode:
authorSpenser Gilliland <spenser@gillilanding.com>2013-07-19 18:37:51 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-28 16:42:48 +0200
commita51b43a68d8e4f4db50bcb1a778d1abd71c121e0 (patch)
tree764b3548dbed9a383b018c13afd49091762a63f3 /package/a10disp
parent0e8cbd5902e471df7b9804bc1328d9134094f1a1 (diff)
a10disp: new package
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/a10disp')
-rw-r--r--package/a10disp/Config.in12
-rw-r--r--package/a10disp/a10disp.mk22
2 files changed, 34 insertions, 0 deletions
diff --git a/package/a10disp/Config.in b/package/a10disp/Config.in
new file mode 100644
index 000000000..b4edf3150
--- /dev/null
+++ b/package/a10disp/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_A10DISP
+ bool "a10disp"
+ depends on BR2_arm
+ depends on BR2_LINUX_KERNEL
+ help
+ Program to change the display mode of Allwinner ARM SOCs running
+ the linux-sunxi kernel (and not the mainline kernel.)
+
+ http://github.com/hglm/a10disp
+
+comment "a10disp requires the linux kernel"
+ depends on BR2_arm && !BR2_LINUX_KERNEL
diff --git a/package/a10disp/a10disp.mk b/package/a10disp/a10disp.mk
new file mode 100644
index 000000000..fee4ac7a9
--- /dev/null
+++ b/package/a10disp/a10disp.mk
@@ -0,0 +1,22 @@
+################################################################################
+#
+# a10disp
+#
+################################################################################
+
+A10DISP_VERSION = a899cc6dcf
+A10DISP_SITE = http://github.com/hglm/a10disp/tarball/$(A10DISP_VERSION)
+A10DISP_LICENSE = MIT
+
+A10DISP_DEPENDENCIES = linux
+
+define A10DISP_BUILD_CMDS
+ cp -f $(LINUX_DIR)/include/video/sunxi_disp_ioctl.h $(@D)/
+ $(TARGET_CC) $(TARGET_CFLAGS) $(@D)/a10disp.c -o $(@D)/a10disp
+endef
+
+define A10DISP_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/a10disp $(TARGET_DIR)/usr/bin/a10disp
+endef
+
+$(eval $(generic-package))