summaryrefslogtreecommitdiff
path: root/package/aiccu
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2014-01-14 11:22:27 +0000
committerPeter Korsgaard <peter@korsgaard.com>2014-01-14 22:26:14 +0100
commit80882ee66177160997ac449851aabce9e92e3333 (patch)
tree5db96ab449aa8b7344f6a58bb6e916022b3cceb2 /package/aiccu
parentc4cc84afc60bbfa34b405ac1589a52087212fd84 (diff)
aiccu: fix undefined reference to clock_* functions
Since glibc 2.17 the clock_* suite functions are available directly in the main C library. For previous versions we still need -lrt to link. Upstream is aware of this problem. Fixes: http://autobuild.buildroot.net/results/c11/c1182b00f9d968e587acba15af4af905b92227f5/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/aiccu')
-rw-r--r--package/aiccu/aiccu-0003-clock-suite-functions-fix.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/aiccu/aiccu-0003-clock-suite-functions-fix.patch b/package/aiccu/aiccu-0003-clock-suite-functions-fix.patch
new file mode 100644
index 000000000..365e72a22
--- /dev/null
+++ b/package/aiccu/aiccu-0003-clock-suite-functions-fix.patch
@@ -0,0 +1,18 @@
+aiccu: fix undefined reference to clock_* functions
+
+Since glibc 2.17 the clock_* suite functions are available directly in
+the main C library. For previous versions we still need -lrt to link.
+
+Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
+
+--- aiccu/unix-console/Makefile.orig 2014-01-14 10:17:20.204602513 +0000
++++ aiccu/unix-console/Makefile 2014-01-14 10:17:31.435777359 +0000
+@@ -42,7 +42,7 @@ CFLAGS += -D AICCU_CONSOLE
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LDFLAGS += -lgnutls -lrt
+ endif
+
+ # Linux