summaryrefslogtreecommitdiff
path: root/package/aircrack-ng
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:48:13 +0100
commit665e13c85e1fd216499cdd335a88a4d1c20f175f (patch)
tree5ecc87c54905105b96cbe9891028ef8eb3d713b1 /package/aircrack-ng
parent2d23d40279be39f70553974de11a5fc088622911 (diff)
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/aircrack-ng')
-rw-r--r--package/aircrack-ng/Config.in2
-rw-r--r--package/aircrack-ng/aircrack-ng.mk8
2 files changed, 5 insertions, 5 deletions
diff --git a/package/aircrack-ng/Config.in b/package/aircrack-ng/Config.in
index d254e21ce..80b3a2b1c 100644
--- a/package/aircrack-ng/Config.in
+++ b/package/aircrack-ng/Config.in
@@ -4,7 +4,7 @@ config BR2_PACKAGE_AIRCRACK_NG
depends on BR2_USE_MMU # uses fork()
# libnl has issues when linking statically
# they need fixing in libnl itself
- select BR2_PACKAGE_LIBNL if !BR2_PREFER_STATIC_LIB
+ select BR2_PACKAGE_LIBNL if !BR2_STATIC_LIBS
select BR2_PACKAGE_OPENSSL
select BR2_PACKAGE_ZLIB
depends on BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/aircrack-ng/aircrack-ng.mk b/package/aircrack-ng/aircrack-ng.mk
index c7fcb63d5..fff4137be 100644
--- a/package/aircrack-ng/aircrack-ng.mk
+++ b/package/aircrack-ng/aircrack-ng.mk
@@ -14,10 +14,10 @@ AIRCRACK_NG_MAKE_OPTS = unstable=true
# Account for libpthread in static
AIRCRACK_NG_LDFLAGS = $(TARGET_LDFLAGS) \
- $(if $(BR2_PREFER_STATIC_LIB),-lpthread -lz)
+ $(if $(BR2_STATIC_LIBS),-lpthread -lz)
# libnl support has issues when building static
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ifeq ($(BR2_STATIC_LIBS),y)
AIRCRACK_NG_MAKE_OPTS += libnl=false
else
AIRCRACK_NG_MAKE_OPTS += libnl=true
@@ -27,7 +27,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBPCAP),y)
AIRCRACK_NG_DEPENDENCIES += libpcap
AIRCRACK_NG_MAKE_OPTS += HAVE_PCAP=yes \
- $(if $(BR2_PREFER_STATIC_LIB),LIBPCAP="-lpcap $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)")
+ $(if $(BR2_STATIC_LIBS),LIBPCAP="-lpcap $(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)")
else
AIRCRACK_NG_MAKE_OPTS += HAVE_PCAP=no
endif
@@ -42,7 +42,7 @@ endif
# Duplicate -lpthread, because it is also needed by sqlite
ifeq ($(BR2_PACKAGE_SQLITE),y)
AIRCRACK_NG_DEPENDENCIES += sqlite
- AIRCRACK_NG_MAKE_OPTS += sqlite=true LIBSQL="-lsqlite3 $(if $(BR2_PREFER_STATIC_LIB),-lpthread)"
+ AIRCRACK_NG_MAKE_OPTS += sqlite=true LIBSQL="-lsqlite3 $(if $(BR2_STATIC_LIBS),-lpthread)"
else
AIRCRACK_NG_MAKE_OPTS += sqlite=false
endif