summaryrefslogtreecommitdiff
path: root/package/amd-catalyst
diff options
context:
space:
mode:
authorRomain Perier <romain.perier@free-electrons.com>2016-08-23 14:19:48 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-23 18:09:45 +0200
commitf0c3cfc2dace594a831d84a5ca05ae96cf81260b (patch)
tree2d6f5654dbdb1622b4f8bd0ca71dd03225982c85 /package/amd-catalyst
parent689ae6e404c8d54a600cb4c62976a9987c08c022 (diff)
package/amd-catalyst: Add command line tools
The AMD Catalyst driver includes some command line tools for displaying specific infos about the GL stack or to test 3D, like fglxinfo or fgl_gears. This commit adds support to install such tools. Signed-off-by: Romain Perier <romain.perier@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/amd-catalyst')
-rw-r--r--package/amd-catalyst/Config.in5
-rw-r--r--package/amd-catalyst/amd-catalyst.mk20
2 files changed, 25 insertions, 0 deletions
diff --git a/package/amd-catalyst/Config.in b/package/amd-catalyst/Config.in
index 1578324aa..b10ed3b11 100644
--- a/package/amd-catalyst/Config.in
+++ b/package/amd-catalyst/Config.in
@@ -40,6 +40,11 @@ if BR2_PACKAGE_AMD_CATALYST_XORG
config BR2_PACKAGE_PROVIDES_LIBGL
default "amd-catalyst"
+config BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS
+ bool "command-line configuration tools"
+ help
+ Build and install the AMD command line tools.
+
endif
comment "amd-catalyst kernel module needs a kernel to be built"
diff --git a/package/amd-catalyst/amd-catalyst.mk b/package/amd-catalyst/amd-catalyst.mk
index aca77816b..4c1844c4d 100644
--- a/package/amd-catalyst/amd-catalyst.mk
+++ b/package/amd-catalyst/amd-catalyst.mk
@@ -109,12 +109,32 @@ endef
endif
+ifeq ($(BR2_PACKAGE_AMD_CATALYST_CMDLINE_TOOLS), y)
+AMD_CATALYST_CMDLINE_TOOLS_FILES = \
+ atiode \
+ atiodcli \
+ fgl_glxgears \
+ aticonfig \
+ amd-console-helper \
+ fglrxinfo
+
+define AMD_CATALYST_INSTALL_CMDLINE_TOOLS
+ $(INSTALL) -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/sbin/atieventsd \
+ $(TARGET_DIR)/usr/sbin
+ $(foreach f,$(AMD_CATALYST_CMDLINE_TOOLS_FILES), \
+ $(INSTALL) -D -m 0755 $(AMD_CATALYST_ARCH_DIR)/usr/X11R6/bin/$(f) \
+ $(TARGET_DIR)/usr/bin/$(f)
+ )
+endef
+endif
+
define AMD_CATALYST_INSTALL_STAGING_CMDS
$(call AMD_CATALYST_INSTALL_STAGING_XORG)
endef
define AMD_CATALYST_INSTALL_TARGET_CMDS
$(call AMD_CATALYST_INSTALL_XORG)
+ $(call AMD_CATALYST_INSTALL_CMDLINE_TOOLS)
endef
$(eval $(generic-package))