summaryrefslogtreecommitdiff
path: root/package/argus
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2015-07-26 20:45:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-26 21:49:57 +0200
commit50e63d67ab64b9b1d40ed77cb0ea08a68276bbba (patch)
treee8fb1f450302473c40d423cbcff0e33ac7c868d8 /package/argus
parent9daa5e3f5570ab4d2f075ca42bfaa82d57db61a1 (diff)
argus: use pkg-config for libtirpc flags
Instead of hardcoding the flags needed for libtirpc, use pkg-config. The linker flags are added to LIBS rather than LDFLAGS, which is more correct in case of static builds. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/argus')
-rw-r--r--package/argus/argus.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/argus/argus.mk b/package/argus/argus.mk
index c39b664ed..bd1c55904 100644
--- a/package/argus/argus.mk
+++ b/package/argus/argus.mk
@@ -13,10 +13,10 @@ ARGUS_LICENSE = GPLv2+
ARGUS_LICENSE_FILES = README
ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
-ARGUS_DEPENDENCIES += libtirpc
+ARGUS_DEPENDENCIES += libtirpc host-pkgconf
ARGUS_CONF_ENV += \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/tirpc/" \
- LDFLAGS="$(TARGET_LDFLAGS) -ltirpc"
+ CFLAGS="$(TARGET_CFLAGS) `$(PKG_CONFIG_HOST_BINARY) --cflags libtirpc`" \
+ LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtirpc`"
endif
$(eval $(autotools-package))