summaryrefslogtreecommitdiff
path: root/package/assimp
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2015-12-17 23:18:18 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-28 22:59:34 +0100
commit30249f33986b31ae96ebed7596476f05372b029f (patch)
tree6376a4ffe70652f585b2a089f4e144c8341f0651 /package/assimp
parenta0c0ed2cf9761f7f14f50746520f621331863057 (diff)
assimp: new package
Signed-off-by: Peter Seiderer <ps.report@gmx.net> ---- Changes v1 -> v2: - use github helper (thanks to Jörg Krause) Changes v2 -> v3: - add c++ dependency (suggested by Thomas Petazzoni) - fix linking problem with builtin zlib (linking code with/without '-fpic' compiled, see e.g. [2]), workaround by selecting buildroot zlib package (failure detected by Thomas Petazzoni [2]) [1] https://cmake.org/pipermail/cmake/2006-March/008482.html [2] http://lists.busybox.net/pipermail/buildroot/2015-December/146859.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/assimp')
-rw-r--r--package/assimp/Config.in14
-rw-r--r--package/assimp/assimp.mk16
2 files changed, 30 insertions, 0 deletions
diff --git a/package/assimp/Config.in b/package/assimp/Config.in
new file mode 100644
index 000000000..35e2f239a
--- /dev/null
+++ b/package/assimp/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_ASSIMP
+ bool "assimp"
+ depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_ZLIB
+ help
+ Open Asset Import Library (assimp) is a portable Open Source
+ library to import various well-known 3D model formats in a uniform
+ manner. The most recent version also knows how to export 3d files
+ and is therefore suitable as a general-purpose 3D model converter.
+
+ http://www.assimp.org
+
+comment "assimp needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/assimp/assimp.mk b/package/assimp/assimp.mk
new file mode 100644
index 000000000..fd556e596
--- /dev/null
+++ b/package/assimp/assimp.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# assimp
+#
+################################################################################
+
+ASSIMP_VERSION = v3.2
+ASSIMP_SITE = $(call github,assimp,assimp,$(ASSIMP_VERSION))
+ASSIMP_LICENSE = BSD-3c
+ASSIMP_LICENSE_FILES = LICENSE
+ASSIMP_DEPENDENCIES = zlib
+ASSIMP_INSTALL_STAGING = YES
+
+ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF
+
+$(eval $(cmake-package))