summaryrefslogtreecommitdiff
path: root/package/aumix
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2007-06-13 10:07:16 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2007-06-13 10:07:16 +0000
commit1c0ead4129a6256eb75fb4f3ce1b3650c6605390 (patch)
tree80c55a76e05d6661a9259548ce1efc7da188edd4 /package/aumix
parent45ac6df37c7b11c00bcec137a4f37a637183dc23 (diff)
aumix package
Diffstat (limited to 'package/aumix')
-rw-r--r--package/aumix/Config.in13
-rw-r--r--package/aumix/aumix.mk65
2 files changed, 78 insertions, 0 deletions
diff --git a/package/aumix/Config.in b/package/aumix/Config.in
new file mode 100644
index 000000000..2d5cdb3d4
--- /dev/null
+++ b/package/aumix/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_AUMIX
+ bool "aumix"
+ default n
+ select BR2_PACKAGE_NCURSES
+ help
+ aumix is a small, easy-to-use program to control the mixer
+ of your sound card. It runs in text mode using the ncurses
+ library, or from the command line (non-interactively).
+ It can read default settings from a file, and it can also
+ automatically save and restore the mixer settings at shutdown
+ and boot.
+
+ http://jpj.net/~trevor/aumix.html
diff --git a/package/aumix/aumix.mk b/package/aumix/aumix.mk
new file mode 100644
index 000000000..440486764
--- /dev/null
+++ b/package/aumix/aumix.mk
@@ -0,0 +1,65 @@
+#############################################################
+#
+# aumix
+#
+#############################################################
+
+AUMIX_VERSION=2.8
+AUMIX_SOURCE=aumix-$(AUMIX_VERSION).tar.bz2
+AUMIX_SITE=http://jpj.net/~trevor/aumix
+AUMIX_DIR=$(BUILD_DIR)/aumix-$(AUMIX_VERSION)
+AUMIX_CAT:=$(BZCAT)
+
+$(DL_DIR)/$(AUMIX_SOURCE):
+ $(WGET) -P $(DL_DIR) $(AUMIX_SITE)/$(AUMIX_SOURCE)
+
+$(AUMIX_DIR)/.unpacked: $(DL_DIR)/$(AUMIX_SOURCE)
+ $(AUMIX_CAT) $(DL_DIR)/$(AUMIX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(AUMIX_DIR)/.unpacked
+
+$(AUMIX_DIR)/.configured: $(AUMIX_DIR)/.unpacked
+ (cd $(AUMIX_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libdir=$(STAGING_DIR)/lib \
+ --includedir=$(STAGING_DIR)/include \
+ --without-gtk \
+ --without-gtk1 \
+ --without-alsa \
+ --without-gpm \
+ --without-sysmouse \
+ $(DISABLE_NLS) \
+ );
+ touch $(AUMIX_DIR)/.configured
+
+$(AUMIX_DIR)/src/aumix: $(AUMIX_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(AUMIX_DIR)
+
+$(AUMIX_DIR)/.installed: $(AUMIX_DIR)/src/aumix
+ $(MAKE) -C $(AUMIX_DIR) DESTDIR=$(TARGET_DIR) install
+ touch $(AUMIX_DIR)/.installed
+
+aumix: uclibc ncurses $(AUMIX_DIR)/.installed
+
+aumix-source: $(DL_DIR)/$(AUMIX_SOURCE)
+
+aumix-clean:
+ -$(MAKE) -C $(AUMIX_DIR) clean
+
+aumix-dirclean:
+ rm -rf $(AUMIX_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_AUMIX)),y)
+TARGETS+=aumix
+endif