summaryrefslogtreecommitdiff
path: root/package/aumix
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/aumix
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/aumix')
-rw-r--r--package/aumix/Config.in12
-rw-r--r--package/aumix/aumix-2.8-fix-incorrect-makefile-am.patch29
-rw-r--r--package/aumix/aumix.mk21
3 files changed, 62 insertions, 0 deletions
diff --git a/package/aumix/Config.in b/package/aumix/Config.in
new file mode 100644
index 000000000..3d3208250
--- /dev/null
+++ b/package/aumix/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_AUMIX
+ bool "aumix"
+ select BR2_PACKAGE_NCURSES
+ help
+ aumix is a small, easy-to-use program to control the mixer
+ of your sound card. It runs in text mode using the ncurses
+ library, or from the command line (non-interactively).
+ It can read default settings from a file, and it can also
+ automatically save and restore the mixer settings at shutdown
+ and boot.
+
+ http://jpj.net/~trevor/aumix.html
diff --git a/package/aumix/aumix-2.8-fix-incorrect-makefile-am.patch b/package/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
new file mode 100644
index 000000000..8d55218bb
--- /dev/null
+++ b/package/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
@@ -0,0 +1,29 @@
+Aumix's src/Makefile.am incorrect adds @includedir@ to the list of
+include paths and @libdir@ to the list of libraries paths. This is
+incorrect, as @includedir@ and @libdir@ are respectively /usr/include
+and /usr/lib, even in cross-compilation mode.
+
+At the same time, use AM_CFLAGS instead of CFLAGS, as is done on the
+similar patch found in OpenEmbedded.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ src/Makefile.am | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+Index: aumix-2.8/src/Makefile.am
+===================================================================
+--- aumix-2.8.orig/src/Makefile.am
++++ aumix-2.8/src/Makefile.am
+@@ -7,9 +7,8 @@
+ mouse.c common.h curses.h gpm-xterm.h gtk.h interactive.h \
+ mouse.h play.xpm record.xpm
+ localedir = $(datadir)/locale
+-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
+-CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
+-LDADD = -L@libdir@
++INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
++AM_CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
+ LIBS = @LIBS@ @GTK_LIBS@ @INTLLIBS@
+ DEFS = @DEFS@
+
diff --git a/package/aumix/aumix.mk b/package/aumix/aumix.mk
new file mode 100644
index 000000000..de0902a4a
--- /dev/null
+++ b/package/aumix/aumix.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# aumix
+#
+################################################################################
+
+AUMIX_VERSION = 2.8
+AUMIX_SOURCE = aumix-$(AUMIX_VERSION).tar.bz2
+AUMIX_SITE = http://jpj.net/~trevor/aumix/releases
+AUMIX_AUTORECONF = YES
+
+AUMIX_CONF_OPT = \
+ --without-gtk \
+ --without-gtk1 \
+ --without-alsa \
+ --without-gpm \
+ --without-sysmouse
+
+AUMIX_DEPENDENCIES = host-gettext ncurses
+
+$(eval $(autotools-package))