summaryrefslogtreecommitdiff
path: root/package/bash
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-10-12 15:36:22 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-12 15:51:38 +0200
commit02e5cef14c6a3bb2ecca05e6f29302ab7f24bf48 (patch)
tree1aab2c24c5d62ab7e1bc6b5f414a465f54149fc0 /package/bash
parent2a8ceecd80baf21df509c96d0cbc9a1b39cd7d4b (diff)
system: add option to choose what /bin/sh points to
Not all our shells do install a pointer to /bin/sh. Besides, between those that do and multiple ones are enabled, the last one to install wins the the symlink. Add a new config choice in the system sub-menu that allows the user to explicitly select the shell to provide /bin/sh. If busybox is not enabled, default to using dash, a POSIX shell. Remove the symlink creation from bash.mk at the same time. Note: for every shell, we select them, except busybox, on which we depend, on the assumption that we do not want to force busybox in case the user decided not to enable it. [Peter: remove redundant !BR2_PACKAGE_BUSYBOX dependency] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index 6510af5e9..34a3a7395 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -35,7 +35,6 @@ define BASH_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
DESTDIR=$(TARGET_DIR) exec_prefix=/ install
rm -f $(TARGET_DIR)/bin/bashbug
- ln -sf bash $(TARGET_DIR)/bin/sh
endef
$(eval $(autotools-package))