summaryrefslogtreecommitdiff
path: root/package/bash
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-08-12 10:15:45 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-08-13 10:17:57 +0200
commit9e0f48c83158655ae737c89df618c5c79294f682 (patch)
treef75224486e81a7c1af17a2008cd76dafea11ebb9 /package/bash
parent4807cdf8a950fda60f32b16caf996d02a3c2273e (diff)
bash: fix static build
The static build needs some trickery, so make it happen. Fixes: http://autobuild.buildroot.net/results/2b12868f8297a96d7abf7fcf526ca5eace73d66d/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index d51e2037d..efd2334ad 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -16,6 +16,11 @@ BASH_CONF_ENV += \
bash_cv_func_sigsetjmp=present \
bash_cv_printf_a_format=yes
+# The static build needs some trickery
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+BASH_CONF_OPT += --enable-static-link --without-bash-malloc
+endif
+
# Make sure we build after busybox so that /bin/sh links to bash
ifeq ($(BR2_PACKAGE_BUSYBOX),y)
BASH_DEPENDENCIES += busybox