summaryrefslogtreecommitdiff
path: root/package/batctl
diff options
context:
space:
mode:
authorJens Zettelmeyer <zettelmeyerj@gmail.com>2015-02-09 20:22:18 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-09 22:45:58 +0100
commit20fcdcb34bfb7e03db1254bc8489c0e20ab31dab (patch)
tree7955717800368d53d77b1ef5da49a8e54b8bd0d0 /package/batctl
parentd09ad2620dac14bff88cba460d0487dcdfb0d3e0 (diff)
batctl: new package
[Thomas: - remove trailing whitespace - remove "# libnl" comment in Config.in - remove BATCTL_SOURCE, which is not needed, since the default value is used - pass $(TARGET_CONFIGURE_OPTS) in the make environment, not as a make option, otherwise the CFLAGS += lines of batctl Makefile do not have any effect, and lead to not have the proper include path to the libnl header files.] Signed-off-by: Jens Zettelmeyer <zettelmeyerj@goooglemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/batctl')
-rw-r--r--package/batctl/Config.in12
-rw-r--r--package/batctl/batctl.hash2
-rw-r--r--package/batctl/batctl.mk21
3 files changed, 35 insertions, 0 deletions
diff --git a/package/batctl/Config.in b/package/batctl/Config.in
new file mode 100644
index 000000000..a60f4f6ad
--- /dev/null
+++ b/package/batctl/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_BATCTL
+ bool "batctl"
+ depends on BR2_INET_IPV6
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
+ select BR2_PACKAGE_LIBNL
+ help
+ Batctl is the configuration and debugging tool for batman-adv.
+
+ http://www.open-mesh.org/projects/batman-adv/wiki/Using-batctl
+
+comment "batctl needs a toolchain w/ IPv6, threads"
+ depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/batctl/batctl.hash b/package/batctl/batctl.hash
new file mode 100644
index 000000000..663e6021d
--- /dev/null
+++ b/package/batctl/batctl.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 77509ed70232ebc0b73e2fa9471ae13b12d6547d167dda0a82f7a7fad7252c36 batctl-2014.4.0.tar.gz
diff --git a/package/batctl/batctl.mk b/package/batctl/batctl.mk
new file mode 100644
index 000000000..c45875214
--- /dev/null
+++ b/package/batctl/batctl.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# batctl
+#
+################################################################################
+
+BATCTL_VERSION = 2014.4.0
+BATCTL_SITE = http://downloads.open-mesh.org/batman/releases/batman-adv-$(BATCTL_VERSION)
+BATCTL_LICENSE = GPLv2
+BATCTL_DEPENDENCIES = libnl host-pkgconf
+
+define BATCTL_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
+endef
+
+define BATCTL_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))